Key mapping problems

Seriously, guys ? After ONE YEAR, you’re still unable to let people assign keys as they like ?

I’ve just tried the GOG “one year” edition. I wanted to remap my keys (because, you know, AZERTY, not QWERTY…), and while I could change the map rotation keys (A and Q), the game wouldn’t let me remap the Z key to “move map UP”.

It keeps saying it is “reserved for show upper floor”, or something like this. When I unbound the key for that specific function (and mapped it to “W”, as it should be on an AZERTY keyboard), the game then told me that I couldn’t map the Z key because it was reserved for “”.

Yep, it wasn’t bound anymore, but it was still protected. Seriously, guys, WTF ???
I hope to see a corrective patch ASAP, because the game sure as hell doesn’t look finished, right now.

Updated the game today, then started it. Tried assigning the “Z” key, once again. Game refused.

I quit. Again.

When can we expect a decent key remapping feature ? One which WORKS ?

Had the same exact problem (AZERTY for me too).
Seems only the “z” key is affected, and it happens to be the last letter of the alphabet.

Devs, could it be that there is somewhere a piece of code like:
“if (key < ‘z’) …”, instead of “if (key <= 'z)” ?

Anyway, solved that irritating problem by assigning an unused key, say ‘j’, to ‘camera up’.
Then in file ‘Bindings.jopt’ inside the save directory, replaced string “j” by “z” (twice).
The line now looks like this: “Name”: “z”

Use your favorite search engine to find the save directory, it’s normally within xxx/AppData/LocalLow/

Good play!


I honestly doubt it’s a loop border condition which causes it (also, I’m a dev too ^^). The game specifically says that it’s because the key is reserved for a certain feature. It keeps saying that even after said feature has been mapped to another key.

Now, the part about the bindings file is really interesting. I’ll have to have a look at it. Thanks !