Great game with many problems still

Hi, don’t know if any further developement is planned for Phoenix point, but the game is still unfinished and still feels like beta even after years from release. Idea and intention behind is great and appreciated but the game is just not finished and fixed. Here are some problems I’d like to point out:

  • disappearing ammo when using add ammo button with class filter being turn in a way that ammo for current weapon is not visible. It’ll consume ammo for that weapon from stock without adding it to soldiers inventory. Ammo will simply disappear just like that. Add ammo button is dangerous to use in this state and it’s safer to just drag and drop it into soldiers inventory

  • sometimes enemy is completely skipping their turn remaining passive, effectively giving player free turn. It feels like cheating this should be fixed

  • filtering in manufacture screen is not working properly - class filter remains colored orange even when turned off.

  • during free aim sometimes soldier is aiming right into wall immediatelly in front of him even when having clear shot

Damn, I thought I was the only one having such problems in the game. Yes, it’s often annoying. And it seems to me that they would rather release a new part than get rid of these bugs. Although even bugs can hardly be called, since they have not been fixed for a long time. Now it’s just a problem

It is finished.

Definitely not. Have you ever tried to play in beta versions of game? Phoenix Point has its issues, but things you mention are not ‘beta’ category.

Like I said. It is finished. But yes it has some bugs left. Program can be finished even when it has glitches. Maybe at some point part of bugs will be fixed, but definitely developers now look on the next projects.

It is because it takes part of ammo from stores and it fills your partly loaded weapon. Ammo which is left is not a full magazine and that is why it doesn’t show up in the stores anymore. But that ammo is not lost. It just doesn’t allow you to take party filled magazine to your soldier. To not have that problem use ‘resupply button’ after each mission. It will replenish partly used magazines and when clicking ‘add ammo’ you will take whole magazine from stores to soldier’s inventory.

bug, but it only occurs when loading a saved game during tactical mission. It is a glitch which works on players favor. Try to not save and load game during tactical mission. Only save on the first turn and then go with combat till the end.

yep, introduced lately - somewhat annoying but not game breaking. Probably won’t be fixed.

yep, this one is since the early versions of the game. Probably won’t be fixed as still not game breaking. You need to try different angles, or shoot without free aim.

For sure. They definitely work on next title (which is not Phoenix Point 2 unfortunately), and won’t come back to Phoenix Point unless there will show up some game breaking bugs.

1 Like

I’ll clarify on that ammo deleting bug because what you’ve described is not the case, but I feel I’m just wasting my time and nerves because devs and project lead probably already know of most issues this otherwise great game has and just doing nothing to correct this, which is sad and disappointing but what do I know…

  • Problem is related to class filters again: If one has for example 10 laser rifle ammo and during filling soldiers inventory with add ammo button has not active assault class filter (because soldier might be sniper with Trooper trait that enables him to use assault rifles, but assault class filter is turned off by default) then after each press of add ammo button - ammo will be deleted from stock and nothing added to soldiers inventory. Simply losing all 10 ammo just like that if pressed 10 times, try it yourself. One must have filter for that weapon enabled, or everything enabled in filters to avoid this. Simply put if filter for weapon class is turned off than add ammo button for that weapon will erase that ammo as many times as pressed. Like I said add button is dangerous to use if not aware of this.

  • Also there is another bug with filters - if you enter into soldiers inventory from flyier crew screen then this is what you get (pic). No filters at all. Then you’ll have to go thru edit soldier button to reenable it again - again bug.

  • One more frustrating bug which I’m sure you’re aware of is disabled abilities during battle if ability is used before and subsequently game is loaded - then ability becomes unaviable. I’ve seen this reported before by other people many months ago just doing google search, so I’m wasting my time again I guess.

Maybe this title is free of gamebreaking bugs but that is absolutly bare minimum that every game must satisfy or not be even released. The fact that there are still frustrating bugs like I’ve described is not acceptable. There should be some disclaimer for people to get ready for some serious dose of frustration, or some kind of tutorial on how to coexist with theese persisting bugs that’ll never be addressed so they’ll not fall into rage while playing.

Well at least you’re being honest about how things are and what to expect or rather NOT expect.