(EGS) LOTA DLC no longer available + stuck on loading screen

Not sure why, but Legacy of Ancients will not load with the Epic Launcher. No matter how many times I uninstall and reinstall the DLC’s or the game.

  1. PP Year Edition is what was purchased
  2. Using the Epic Launcher
  3. Yes I’ve uninstalled the DLCs and reinstalled them
  4. Yes I’ve uninstalled the game and reinstalled it.
  5. Verified the files through the Epic Launcher
  6. Disabled auto synch.

I still can’t get the option to run Legacy of Ancients when I try and load a new game, and my old saves won’t run without it.

What’s going on? I’ve checked out the other solutions and I’ve pretty much done what they’ve instructed and nothing has resolved it. This isn’t a new bug, so I’m pretty much stuck and looking for a solution.

@Yokes not only for new campaigns - my all saves are corrupted :confused:

I have got the same issue. All save files corrupted. When I try to enable the Legacy of the Ancients DLC the game tries to redirect me to store page which results in 404 Error message.

Corrupted Horizons for you …


And now, a new game without the dlc doen’t show the soldiers in edit window. Have you been bought by Asmodee?

@Yokes Thanks for the response.

I’d like to second what @vogello brought up… all of my saved games are also not working when the Legacy of Ancients DLC was working fine. Getting the same error and behavior as @Vogello.

Let me know if you guys need any system info to help narrow down the issue.

I suppose it is affecting all EGS installations. With and without DLC4. No matter if it is new or old campaign. Snapshot need to fix some recognition of version of the game, and what assets can be loaded by the engine.

You can help by pressing F10 button and submitting report with explanation what happened. I think there is enough information about system specification and game state to help developers.

The game downloaded a patch which made the game work again. Everything is up and running now. I hope it stays this way.

1 Like

I bought Phoenix Point, now it is 1.13.72080. I had got Ancient Legacy and it shows in EGS and I’ve been playing it. Now it shows the DLC as Not Available in game and I cannot load saved games (because they used the DLC). Any solution for this issue?

The game worked perfectly before the last update.
Now i can’t do the first mission when i start a new campaign, the game freeze on the loading screen when i click on the “deploy mission” button.

And before that, the soldiers are not shoed on the screen when i click on their status to give them weapons, nades etc …

i run with

win 10
amd ryzen 7 3700x 8 core 3.6gz 16go
Nvidia geforce RTX 2070 super

please help ! can’t run this interesting game its really a pity !

I have the exact same problem. I also can’t load any of my previous saves because it says I need the Legacy of the Ancients DLC, which has disappeared from the epic games store.

I also tried verifying in Epic Games launcher, and uninstalling and reinstalling, but still have the same problems.

yea same thing for me, any previous games were unavailable to play, like you i tried verifing, uninstall and reinstall but it doesnt do a thing …
we need help !

if someone can tell us how to download the previous version of the game, it would be cool, in order to play this version without bugs, and to keep time to devs to fix the bugs of the V1.13 …

I suppose you need to wait few days. I think this is their priority right now and fix should be available as soon as possible. Probably you will still play earlier than GOG users which need to wait for update.

yea i 'm ok with waiting for fixes , thats just a little bit frustrating to have saves no longer available and not have the game run properly on 1st mission.
Its just that i m in france, it’s friday night and it will be a f…ing rainy weekend … so i hoped tyo spend more time to play and learn about this game … i 'll wait no pb ! :smiley:

Cool. I’m back after almost a year, updated today, and I can’t start a new game :frowning_face:
If it matters, I have the original game (i.e. no Year One Edition) with no DLC at all.

I’ve tried disabling the tutorial / prologue, and it started - on veteran.

Yep, that really seems to be the culprit. I exited to main menu (without closing the game) and started a new game, selecting “play tutorial / prologue” and yet the loading is stuck.

Closed the whole game, relaunched, started a new game without the tutorial and the campaign starts.

Nah, it’s broken: I have no music, soldiers aren’t visible in the equipment screen, the mission doesn’t start because the loading screen ends with an error message stating that some files are corrupted and I should reinstall - and the player.log file is filled with errors.

Hope to see a fix pretty soon.

Of course all these bugs - I was there when that Arthron Umbra killing bug made the game crash - restrain me from buying any additional content.

Hello again,

i decided to play this morning a new campaign, and it s ok now, the game work correctly that’s great !
There’s only the “living weapons” dlc that is missing ( i have the one year edition game) .
I don’t know if old saves are still corrupted because i deleted all old saves so …
Music on geoscape and some missions dissapear too. But it’s not so important to me .

Thank you devs for you quick work ! You’re good !

1 Like