Controller/Mouse bug after Derleth Update

I was playing the game just fine before the last update, with a ps4 controller usb plug. After the update in the geoscape if the controller is connected the screen just goes around and around. If I unplug the controller the movement stops but I cant select anything with the mouse.

If I start a new game (controller pluged) ,the tutorial mission, the camera keeps going to the edges of the map. If I use only the mouse I can move the poiner around but as soons as I select a location it deselects afterwards.

Any Ideas how to help me out with this? I believe I was about half way past the mid of the game.

Do you just have the controller, or do you also have a HOTAS/Flight Stick connected?

Did you map any of the controller keys within the game? Secondly unplug the controller for mouse use only and restart the computer. Typically, the drivers will reload and detect just the mouse.

Using mouse only and since the last fix, clicks on any options are very erratic. On Geo, can take up to three times to get the move action working. Clicks on equipment in deploy screen takes me to Geo etc… Have restarted the game and even the machine with no better result.

After more investigation, found out that there was a windows 10 update about at the same time… Uninstalling mouse drivers and re-plugging the mouse has solve the problem…


@UnstableVoltage I have only the controller. (I also have a HDMI cable connected to play on the TV)

@Ementrude Im using the default configuration. I have already done that and still no luck. I also have uninstalled the game e reisntalled just in case something might had been corrupetd in the update but no luck either.

@ToutUnHomme I have only updated the game a few days ago, not sure if that would be the case here. I still would like to play with the controller though =(

Perhaps remove the controller from windows and reinstall the controller again. This seemed the work for ToutUnHomme.

I tried with both the controller and the mouse driver.

The mouse problem was fixed, thanks guys =D

However the controller still has the same problem. It goes to the middle of the ocean and spins around a specific point.

I try to change locations but it quickly goes back to the ocean and spins around, like rotating the map =(

It sounds like one of the sticks isn’t quite centering so the game is detecting a constant, if small, input.

Is there a setting in your controller software to adjust the deadzone of the sticks?

The Windows software will allow you to recalibrate the device. This will probably correct the issue as UV is suggesting.

Hey guys! Im bring some weird updates.

I tried recallibrating the controller and that didn’t work. I tried a second ps4 controller just in case my first could be malfunctioning and it also didn’t work not even with the calibration.

Also the mouse started to get messed up again, as soon as the ps4 controllers got conected. (I connected one at a time, always turning the game off)

However I tried using a ps3 controller and it worked perfectly. Even the mouse when I tried using.

(Maybe its some incompatibility with ps4 controller - since my pc recognizes my ps4 controller as a xbox360 controller)

Anyway I can go back to my play now.

Thanks everyone, I appreciate a lot.