Can't load cutscenes and game freezes after I exit to desktop


I am playing PP from around one week now, however I am constantly stuck with two main bugs:

  1. can’t load ANY cutscene, no game intro, faction intro or aircraft landing.
    I have a GE force GTX 970 which I updated with the last divrers, but nothing.
    Also i set the Epic game .exe file to run as administrator. I tried also with the PhoenixPoint.exe file but the game was not starting, so I removed the privilege.
    I also dowloaded the latest patch and tried to start a new game, but nothing worked.

  2. I am unable to exit the game. If I click “exit to desktop” the screen freezes and, when I go to Task Manager to force the halt, I found out that the whole system is frozen.
    Only way out is to restart the whole system .

Any help?

Thank you

The lack of cutscenes sounds like a video codec issue. Which version of Windows are you running? Do you have Windows Media Player installed?

Dear UnstableVoltage

The windows version i have does’t have windows media player and it seems i am unable to download it.

Is there another media player that would work as well?

Thank you

I had the same problem with Windows 10 Education N. I was able to fix it by installing the Windows 10 media feature pack. Hope this helps.