Bug on mission "The Crystal Crossbow"

Hello ! :slight_smile:
I cant procede with this mission, because the char is on the objective field! Dont appear the action button and if i destroy the tablle, mission fail

2 Likes

Same issue. Any work around?

I didn’t have this issue… so I’d wonder if reloading the save before the mission and starting again would change its location or not?

I tryed dos this, dont work, still on same place :frowning:

Obter o Outlook para Android

I had the same issue, but I was able to destroy the chair by shooting at it. The first time I used Destiny III and it blows additionally the ground so that the mission fails. The second time I do it with a sniper rifle (+ Sneak Attack, so 240 damage, I don’t know if normal damage is enough to destroy it) and this time it destroyed only the chair. The tile with the objective was free and I was able to end the mission successful.

So don’t use burst weapons or explosives, I think Hell II would be the best solution, and aim careful so that you not shot the ground.

3 Likes

Well, i will try this, tks for the tip

I had the same issue just now and didn’t think about destroying the chair. I will reload the game now and finish it now. It does give you the exactly same map if you reload and play it again. I believe that each mission is probably given a seed number when you get the mission and that seed number is then used to create the map resulting in you getting the same map each time you reload the game.

This worked form me now, ty.

I had tried to shoot the chais, but I used several burst weapons. Single shot from high power sniper rifle did it. Ty

2 Likes

Same here, got with hell II, tks a lot!

I am also stuck here, Did anyone found the solution?

You only have to read my post above :stuck_out_tongue:

OK, again in short:
Just shot the chair with a single bullet weapon with enough damage and aim so that you not additionally destroy the ground below the chair. Then you can get to the tile with the mission goal.

Thank you! would never thought to bring my sniper there…unloaded a whole magazine of Piercing rounds and chair still lived…then I started down the road of explosions…then I came here lol!

Nobody else seems to have mentioned this method yet, but I’ve found that using the ‘Demolition State’ ability of an operative with the Juggernaut Bionic torso (requires Blood & Titanium DLC) is the quickest and most reliable way to bust the chair that is blocking the blue tile and complete the objective.

That same operative with the Juggernaut torso can also, upon completing the objective, Kool-Aid Man their way out of the commander’s office to jump down three storeys like a movie superhero and be well on their way to the evacuation zone, all within the same turn :kissing_smiling_eyes:.

If anyone can come up with a more cinematic workaround to the chair bug, I would like to hear it (or read it) :upside_down_face:.

2 Likes