[Bug] On a machine with 2 GPUs, the game does not select the dedicated GPU

PC: Surface Book 2, Intel GPU + Nvidia GPU 1050
Game installed via Xbox Game Pass
Latest NVIDIA drivers installed. GeForce Experience installed.

Start the game
Start the process manager and take a look at the GPU

Actual: Intel GPU is used (20 FPS at super low settings )
Expected: Nvidia GPU to be used

Hey that’s not a problem of the game but a problem of Win10.

Just found out recently myself.

To use a dedicated GPU in Win10 you have to go to the windows display settings and chose “high performance” for EVERY single program (.exe / .com) that you want to use the faster GPU for!!!

Edit: also very important: don’t run your notbook on battery but use the plug - Win10 will cut CPU and Ram Performance by half each if run on battery

1 Like

That’s a common occurance when gaming on PC with multiple GPUs. Go to NVIDIA control panel>Manage 3D settings>ProgramSetting

Find Phoenix Point (should be there if you launched it recently, or find .exe manually) and then choose which card you want it to use.