PhysX on GPU setting

I’d like to confirm if it’s just my imagination but when I switched the PhysX explicitly to be processed by GPU in NVIDIA settings, the game began to flow smother.

I am no nVIDIA card user, but I remember well PhysX was always been promoted as optimised for that series of GPUs