Tactical Game Crashing - Game Unplayable

The game is currently unplayable due to crashing on the Tactical Screen.
Screen goes black, sound continues and can hear the response as the pointer moves over objects, then sound cuts out.
It then either hangs or drops back to desktop with no crash screen.

Crash occurs in the following situations at seeming random times but usually after the first turn.

  • Player movement
  • Player attacking
  • Player scrolling
  • Player rotating the screen in both Fixed and Free mode
  • Player zooming during attack

Has not occurred in the following situations:

  • accessing backpack

Combing through the logs found the following persistent error:
d3d11: failed to create staging 2D texture w=128 h=2 d3dfmt=10 [887a0005]
d3d11: attempt to lock null buffer

Tried the following:

  1. Updated Drivers
  2. Restarted PC
  3. Reduced graphics to minimal
  4. Forced DirectX reinstall
  5. Reinstalled Game
  6. Reinstalled Unity assets

Problem still persists.

My system is more than adequate to handle the game:
Win 10
Core i7-6800k
16Mb RAM
GeForce GTX 1070

Just had this issue as well, was setting up an overwatch and it froze, I clicked and could hear the soldiers response as if the overwatch was setup but the game remains frozen as if I am just looking at an image.

This was in one of the new rescue soldiers missions

Ok third time I tried to play the mission and it crashed my PC =S not sure I can progress at this point

Little update to this, I took a look in the logs too and found these consistent errors:

d3d11: failed to create 2D texture shader resource view id=5288 [D3D error was 80070057]
d3d11: failed to create staging 2D texture w=128 h=2 d3dfmt=10 [887a0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 240) [0x887A0005]
d3d11: attempt to lock null buffer

[INFO] 37791 (883.285): Exiting UI state UIStateTacticalOptions. Stack contents: StateStack: PhoenixPoint.Tactical.View.ViewStates.UIStateCharacterSelected

Ok, update.
Thanks go to the team at Liftoff for this fix, still no word from Snapshot Games. I mean not even an acknowledgment that there is an issue, really really disappointed with this developer.

Anyway, check to see if you are running something like Citrix Workstation. I require Citrix for work, but it can interfere with the d3d apparently.

This link shows how to get around the issue. I have not had a lock up since and have actually been able to play the game.

You can find other threads with such issue, so devs are aware. And currently they are short on community staff to respond to each thread.