Game crashing to Desktop when beginning Tactical mission

Today I ran the game after the Danforth Update from Epic Store.

From the Title Screen, I could see random circular colored particles (I think it’s supposed to be shining stars on something like that), which I was able to report via F12.
After I started a new game, the amount of particles on Geoscape drastically increased (I managed to report it via F12 as well).
After I scouted the 1st marker, it gave me a Anu Haven infested with Fire Worm mission. But as soon as I hit the “Confirm” button, the games freezes, and after a few seconds (usually less than 10), it crashes to Desktop.
I started a 2nd game, saved prior to scouting the 1st marker, and got the same kind of mission, and the same Crash to Desktop problem.
I updated my NVidia Driver to lasted available, and selected a clean install for it. Still the same problem when starting a new game.
Can’t test on older savegames since I deleted all of them as a saw a few recommendations of starting anew after major updates lake Danforth.

Bottom line, the game is unplayable on my machine now.

Windows 10 Home 64 bits
Intel i5-4590
nVidia GeForce GTX 970
Main Monitor: Dell P2418d (1440p) and Samsung 23" (1080p)

It seems that my problem may be a Graphics Card problem.

I was playing every game normally until last week, but I had to turn my computer off for 5 days, and after I rebooted it, it’s showing problems on some games (Phoenix Point, Gears Tactics, The Outer Worlds, which are 3 of the more “modern” games I play).

On others games, which are much lighter, the Intel Integrated Graphics seems to be handling (Endless Sky and Galactic Civilizations III, the last one being RAM hungry instead of CPU / GPU hungry).

Just a random thought: try to update DIrectX and Microsoft Visual C++ Redistributable (

As you have problems with more games it will probably be some general issue. But you can still try writing here:

1 Like

Thanks, I’ll give it a try and reply.