stuck on black screen

What can I do about this problem that was stuck on the black screen when the game first opened

video link

there is another thread that has numerous suggestions that can potentially fix the issue

I have looked at this comment, I could not see a solution to the problem

sorry to hear that. Hopefully it gets fixed for you folks soon

thank you for your interest

Did you try downloading the “Visual Studio 2015, 2017 and 2019” redistributable? That worked for me. I can’t tell from your video if you are able to see the game cursor, which would point towards this being the issue. (See screenshot below for reference)

Obviously, you need the correct one for your system but most likely you’re using an x64 operating system if you’re on win7 or win10…

amd ryzen 1500x processor rx580 graphics card 16gb 3200mhz ram 64 windows 10 64 bit. When you open the game in the video just have a mause emblem in siah screen can not do any other operation. I have downloaded visual studio which one do I need to install.

I don’t think you should install the VS IDE. If at all, you want to install the VC/VC++ redistributables, which are something different. But I think such dependencies should have been covered by the devs. I can’t believe they’re that incompetent… It must be something else.

The file named vc_redistx64.exe cause you’re running windows 64 bit.

Actually, from what I understand these sorts of dependencies are quite easy to miss because they can be hard to track.

That’s why some games just go the overkill route and install various versions of these redistributables in case they forgot something or overlooked something cause you can’t control every customer environment that the game will be run under.

I have installed the program you sent, but the error still continues :S

Sorry it didn’t help! Hope you find some other way. That thread linked above by kings_rook has some more advice in it where people suggested changing the language and region of windows to English (American). Maybe have a read through of the thread for more information.

thank you for your interest and your valuable time

@KARNA did you solve the problem? I had the same situation and solved it right now. I installed the VC redistributable 64 bit and voilà!

This means the link above may not be the original Microsoft redistributable and sincerely I don’t care what it actually is. Just an advice: don’t install anything from third party sites, these packages require administrator privileges and you don’t want to do that with less than 100% secure software.

The link I used is on Microsoft’s site, so it’s more reliable. It may look like the same as the above but, really, this one worked for me. This is the original " Visual C++ Redistributable for Visual Studio 2015", don’t trust any others:

problem solved thank you for your interest

At first, game could launch very slowly just by itself.
At second, during first launch it could wait for your decision whether to allow traffic through Windows Firewall or not.
At third, you can Alt + Tab and/or look into Task Manager what’s going on. If there is hich CPU/Memory consumption of PP process then most likely game is loading itself.

These VC distros are older ones i guess, windows won’t let me install says i already have. Any other solutions?

For me the issue was codec related. I use Shark007 codec pack. A little while back I had to play around with the settings because subtitles weren’t working with certain file formats. When I first tried PP I had the same blank screen error. However after changing the Shark007 settings back to default the game has worked fine since. If you use a codec pack try updating to the latest version, or update them individually. Also if you know that you have played around with codec settings in the past then try setting them back to default.

Thanks - new windows install and same issue. Now sorted with VC++ 64.

Very surprised game would ship with this fault, however perhaps I shouldn’t be…

I didn’t get chance to revisit this thread for a while but, just to clarify - the links i provided were all to Microsoft’s site so i don’t understand what you were saying here…