Some haven defence saves can't be loaded

As the title of the thread says, some of the haven defences are bugged so that if you save you can’t load that save: you just get an error message and get back to the main menu. Also trying to load such save makes it so that if you try to load any other save after that, the game just stucks on loading screen. Only way to load another save is to close the game and try again, this time not loading the broken save. I have sent couple of bug reports of these.

At first I thought that the fault is in some of the New Jericho haven maps with Scylla on the field but after playing the game for more I suppose the problem is either a Scylla with Death Belch or Monster Leap ability or a Scylla with both. I can’t really see any other skill / progression combo since all haven defences loaded nicely without Scylla or with Scylla which had different abilities. The problem also seems to persist despite the Scylla is dead or alive. Also the bug can be repeated by loading the autosave before haven defence since the Scylla will remain in the enemy group.

Does anyone else have similar experiences? If you have, please check if you also have Scylla on the field and which abilities does it have :slight_smile: The good thing is that you can play the haven defence through normally, just don’t save and load during the mission.

1 Like

yes, that was introduced in the latest patch. Its not just haven defense missions… its pretty much EVERY mission. So if you screw up, your only recourse is to restart or load the autosave.

Yep, i’m getting the same problem. massive pain the ass. i tried turning off epic cloud save since i thought that might have been it and i’ve tried running the PP .exe directly from the install directory so Epic isnt involved pre launch… nada. ive waisted hours of time today trying to get through one extreme haven defence.


Same issue with saves, same problem being stuck on a very difficult haven defense mission.