Mission "The Plan" for Jericho can't be completed

I’m not entirely sure if this is a bug or if I’m missing something obvious and crucial…

Anyway, I’m currently at the end of the mission “The Plan” for Jericho, where the objective is to defeat the gatekeepers, defeat the Yuggothian Receptacle and finally place a beacon.

The gatekeepers are down, the gate is open and the receptacle has been defeated from long range - but my soldiers can’t advance beyond the gate, as the territory beyond it is all X-ed out, and so the mission can’t be completed.

Any takers?

This is definitely a bug.
Have you use F12 ingame to make a bug report? If not, then do this, then the devs get your save with all informations at this point of you play through and can look on it.

Thanks mate, I’ll do that right away.

Does restarting the mission makes it go away?

Same thing. Standing by an archway but the game won’t allow to cross it


I have tried to restart the mission twice with the same Result. Can’t go past the archway

Make a quicksave and try loading it. May have to exit game for this to work.

1 Like

Dang, I forgot to come back here and report the result. I blame the night shifts I had to do…

Anyway, loading up the save did indeed fix the problem!